Back to overview
Degraded

Portal Display Issues

Sep 30 at 08:00am CEST
Affected services
Employees Portal

Resolved
Sep 30 at 09:19am CEST

Portal display restored. All functionalities are now operating as expected.

Created
Sep 30 at 08:00am CEST

Degradation in portal display. Some elements might not be showing correctly. Our team is already working on a fix.